using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+=\""[^\""]*?\"")";
string input = @"<lolz>
<>
<meh crap=""shit"">
<bullshit turds=""dick"" crap=""lolz"" meh=""turds"">
random
random
</bullshit>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}