$re = '/(ourcompany.com\/\w+\/)/m';
$str = 'http://ourcompany.com/theapplestore/...
http://ourcompany.com/anotherstore/...
http://ourcompany.com/yetanotherstore/...';
$subst = "{{store url=''}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;