#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "LG-D85(5|0|2|1) |LG(L|U)S990|VS985"
Local $sString = "Mozilla/5.0 (Linux; U; Android 5.0; iw-il; LG-D855 Build/LRX21R.A1424924275) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 " & @CRLF & _
"Mozilla/5.0 (Linux; Android 5.0.1; LG-D851 Build/LRX21Y; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 " & @CRLF & _
"Mozilla/5.0 (Linux; U; Android 5.0; en-us; LG-D850 Build/LRX21R) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 " & @CRLF & _
"Mozilla/5.0 (Linux; Android 5.0.1; VS985 4G Build/LRX21Y) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.93 Mobile " & @CRLF & _
"Mozilla/5.0 (Linux; Android 4.4.2; LGLS990 Build/KVT49L.LS990ZV4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.78 " & @CRLF & _
"Mozilla/5.0 (Linux; Android 4.4.2; LGUS990 Build/KVT49L.US99010c) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.93 " & @CRLF & _
"Mozilla/5.0 (Linux; Android 5.0.1; LG-D852 Build/LRX21Y) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.93 Mobile "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")