#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img.*src="([^"]+)"
Local $sString = "<div dir="ltr" style="text-align: left;" trbidi="on">" & @CRLF & _
"<div style="text-align: center;">" & @CRLF & _
"<img border="0" height="355" src="http://i.imgur.com/8OplH.png" width="728">" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")