import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*src=\"([^\"]+)";
final String string = "<div dir=\"ltr\" style=\"text-align: left;\" trbidi=\"on\">\n"
+ "<div style=\"text-align: center;\">\n"
+ "<img border=\"0\" height=\"355\" src=\"http://i.imgur.com/8OplH.png\" width=\"728\">\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}