$re = '/(?<=[^x]|^)(x{3}|x{5})(?:[^x]|$)/m';
$str = 'xxx
xxxxx
xxxx xxx x xxxxx
xx xxxxx xxx
xxxxxx
xxx
xxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);