$re = '/^(\d*)(-)?(\d*)?$/m';
$str = '3
1000
15-20
20-15
10-20/2
1-1000/20
Above should be legal; this and below should be illegal
3
03
2 43
2x3
23x
15 - 20
15--30
15-03
15-20-30
1 5-20
15-2 0
15-/20
15/2-2
15/10/2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);