import Foundation
let pattern = #"^(\d*)(-)?(\d*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3
1000
15-20
20-15
10-20/2
1-1000/20
Above should be legal; this and below should be illegal
3
03
2 43
2x3
23x
15 - 20
15--30
15-03
15-20-30
1 5-20
15-2 0
15-/20
15/2-2
15/10/2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}