import re
regex = re.compile(r"(?<=\d)(?=(\d{3})+(?!\d))")
test_str = "2244511556654445454454566436"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)