$re = '/(?<variable>[^| :=\r\n]+)\s*=(?<value>[^|\r\n]+)/';
$str = 'JobName :: Variable1 = 1 | Variable2 = 2 | Variable3 = 3
JobName :: Variable1 = 123456 234567 | Variable2 = asdf q s | Variable3 = as123!@#/*()
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);