package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(?:\?s=.*)`)
var str = `urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php
urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php
urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php
wmaraci.com/forum/uyeler.php?s=barisyilmaz/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}