re = /(.*)(?:\?s=.*)/m
str = 'urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php
urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php
urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php
wmaraci.com/forum/uyeler.php?s=barisyilmaz/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end