$re = '/#
# DocBlock to PHPDoc
#
# @author Richard Fussenegger <richard@fussenegger.info>
#
# Original phpDocumentor RegExp
#[ \t]*(?:\/\*\*|\*\/|\*)?[ \t]{0,1}(.*)?
#
(?:^\s*\/\*\*\s+(?:\*[ \t]?)?|\s+\*\/\s*|[ \t]+\*[ \t]?)
/x';
$str = '/**
* This is a summary.
* This is a {@internal beautiful}} description.
*
* @see \\SimpleXmlElement the XML reader with which this object is constructed
* @var \\SimpleXmlElement {
* The configuration root node that contains all settings for this component.
* @property string \\$name
* @property integer \\$version
* }
*/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;