#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\\)(\\[\w\.\-_]+){2,}(\\?)$"
Local $sString = "\\computer-name\drive\optional_folder1\optional_folder2\" & @CRLF & _
"\\computer_name\drive\optional_folder1\" & @CRLF & _
"\\computer-name\drive\" & @CRLF & _
"\\192.168.1.1\drive\" & @CRLF & _
"\\computer-name\\drive\" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")