package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\\)(\\[\w\.\-_]+){2,}(\\?)$`)
var str = `\\computer-name\drive\optional_folder1\optional_folder2\
\\computer_name\drive\optional_folder1\
\\computer-name\drive\
\\192.168.1.1\drive\
\\computer-name\\drive\
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}