use strict;
my $str = 'I have 24.56 of something.
<a href="345.jpg">345</a>
<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>
<p>abcdefg 5 hijklmnop<span style="some">45,56</span>.</p></br>';
my $regex = qr/[0-9]*,?[0-9]+(?=(?:(?!<\/?p\b)[\s\S])*<\/p>)/p;
my $subst = '$1${2}1000000000000';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";