using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:!|\G(?!^))\K(abc|123)(?=(?:abc|123)*!)";
string input = @"!123abcabc123!123abcabc123";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}