package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s\S]*Subject\s*:.*([\s\S]+)`)
var str = `From: Jeremy<br />
Sent: 22 Apr 2016 12:08:03</br />
To: Mark<br />
Subject: Another test email<br /><br />
Hi Mark,
<br />
Subject : ghfghfh
I'm sending this email as a way to test the email!
<br />
Cheers,
<br />
Jeremy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}