use strict;
my $str = 'WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0
WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0';
my $regex = qr/(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)/mip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";