re = /(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)/mi
str = 'WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0
WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result