$re = '/(<desired_password>)/';
$str = 'bilbo <desired_password> <desired_password>';
$subst = "stuff";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;