$re = '/^(?>(\w{3,})(?=\1))+/';
$str = 'dogdogdogcatcatfish';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;