$re = '~(\.[^:/]+).*$~m';
$str = 'http://www.google.com/path
line2
line3';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;