re = /(\.[^:\/]+).*$/m
str = 'http://www.google.com/path
line2
line3'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result