#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+<del.*?>.*?(<\/del>\w+|<\/del>))|(<del.*?>.*?<\/del>\w+)"
Local $sString = "<del>Within word</del>" & @CRLF & _
"WordEnd Tutorial<del class="ice-del">Within word</del> WordEndsample<del class="ice-del">total word</del>Welcome o RegExr v2.0 by gskinner.com!" & @CRLF & _
"" & @CRLF & _
"Tutorial <del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!" & @CRLF & _
"Tutorial <del class="del">Within word</del>WordEnd sample<del class="del">total word</del> Welcome to the site!" & @CRLF & _
"Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")