package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+<del.*?>.*?(<\/del>\w+|<\/del>))|(<del.*?>.*?<\/del>\w+)`)
var str = `<del>Within word</del>
WordEnd Tutorial<del class="ice-del">Within word</del> WordEndsample<del class="ice-del">total word</del>Welcome o RegExr v2.0 by gskinner.com!
Tutorial <del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
Tutorial <del class="del">Within word</del>WordEnd sample<del class="del">total word</del> Welcome to the site!
Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}