#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[a-zA-Z]{1,2}(?:\.[a-zA-Z]{1,2}){2,}\b"
Local $sString = "a.b.c" & @CRLF & _
"ab.c.dd.ee" & @CRLF & _
"a.b" & @CRLF & _
"aaa.b.cc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")