using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-zA-Z]{1,2}(?:\.[a-zA-Z]{1,2}){2,}\b";
string input = @"a.b.c
ab.c.dd.ee
a.b
aaa.b.cc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}