re = /\b[a-zA-Z]{1,2}(?:\.[a-zA-Z]{1,2}){2,}\b/m
str = 'a.b.c
ab.c.dd.ee
a.b
aaa.b.cc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end