package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\\]+)(?:\.exe)`)
var str = `\"D:\\src\\repos\\myprj\\bin\\Debug\\MyApp.exe\`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}