Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=\b)[,.'-:"]+(?=\s|$)|"
/
g
Input 1
1
New
I've found the regex to locate all hyphenated and "apostrophied" words: Examples: l'Equipe and action-oriented I'm not sure how to utilize this information to get what I want after a bit of searching...