import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\b)[,.'-:\"]+(?=\\s|$)|\"";
final String string = "I've found the regex to locate all hyphenated and \"apostrophied\" words:\n\n"
+ "Examples: l'Equipe and action-oriented\n\n"
+ "I'm not sure how to utilize this information to get what I want after a bit of searching...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}