const regex = /(?<=\b)[,.'-:"]+(?=\s|$)|"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\b)[,.\'-:"]+(?=\\s|$)|"', 'g')
const str = `I've found the regex to locate all hyphenated and "apostrophied" words:
Examples: l'Equipe and action-oriented
I'm not sure how to utilize this information to get what I want after a bit of searching...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}