import re
regex = re.compile(r"(?<=\b)[,.'-:\"]+(?=\s|$)|\"")
test_str = ("I've found the regex to locate all hyphenated and \"apostrophied\" words:\n\n"
"Examples: l'Equipe and action-oriented\n\n"
"I'm not sure how to utilize this information to get what I want after a bit of searching...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")