re = /(?<=\b)[,.'-:"]+(?=\s|$)|"/
str = 'I\'ve found the regex to locate all hyphenated and "apostrophied" words:
Examples: l\'Equipe and action-oriented
I\'m not sure how to utilize this information to get what I want after a bit of searching...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end