import Foundation
let pattern = #"(?<=\b)[,.'-:"]+(?=\s|$)|""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I've found the regex to locate all hyphenated and "apostrophied" words:
Examples: l'Equipe and action-oriented
I'm not sure how to utilize this information to get what I want after a bit of searching...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)