$re = '/[\W\d_](?<![^\W\d_]-(?=[^\W\d_]))/m';
$str = 'Attended pre-tender, etc meetings.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);