re = /(\d+)\.(\d+)\s*-\s*(.+?)(\n)(?>\d|$)/
str = '1.1 - Hello
1.2 - world!
2.1 - Some
data
here and it contains some 32 digits so i cannot use \\D+
2.2 - Etc..'
# Print the match result
str.match(re) do |match|
puts match.to_s
end