using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<cfmail
(?:
\s+to=""(?<to>[^""]+)""
|
\s+from=""(?<from>[^""]+)""
|
\s+subject=""(?<subject>[^""]+)""
|
\s+type=""(?<type>[^""]+)""
)+
>
.*?<\/cfmail>";
string input = @"<cfmail to=""#toAddr#"" from=""#fromAddress#""
subject=""#subject#"" type=""html"">
#emailMsg#
</cfmail>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}