import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<cfmail\n"
+ "(?:\n"
+ " \\s+to=\"(?<to>[^\"]+)\"\n"
+ " |\n"
+ " \\s+from=\"(?<from>[^\"]+)\"\n"
+ " |\n"
+ " \\s+subject=\"(?<subject>[^\"]+)\"\n"
+ " |\n"
+ " \\s+type=\"(?<type>[^\"]+)\"\n"
+ ")+\n"
+ ">\n"
+ ".*?<\\/cfmail>";
final String string = "<cfmail to=\"#toAddr#\" from=\"#fromAddress#\" \n"
+ " subject=\"#subject#\" type=\"html\">\n"
+ " #emailMsg#\n"
+ "</cfmail>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}