const regex = /<cfmail
(?:
\s+to="(?<to>[^"]+)"
|
\s+from="(?<from>[^"]+)"
|
\s+subject="(?<subject>[^"]+)"
|
\s+type="(?<type>[^"]+)"
)+
>
.*?<\/cfmail>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<cfmail
(?:
\\s+to="(?<to>[^"]+)"
|
\\s+from="(?<from>[^"]+)"
|
\\s+subject="(?<subject>[^"]+)"
|
\\s+type="(?<type>[^"]+)"
)+
>
.*?<\\\/cfmail>', 'gs')
const str = `<cfmail to="#toAddr#" from="#fromAddress#"
subject="#subject#" type="html">
#emailMsg#
</cfmail>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}