const regex = /^[a-z](?:[a-z\d]|[a-z\d]\-)*[a-z\d]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z](?:[a-z\\d]|[a-z\\d]\\-)*[a-z\\d]+$', 'gm')
const str = `ab9cd-a9bc-abbbc95
ab9cd-a9bc-abbbc-asdfasd-asdf-2323324vc-95
5abcd
abbcd-fsjs-g-e-wa-q
-abcd
abcd--abcd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}