$re = '/<i class="test(.*)(">)/';
$str = '<div class="test"><a href="../toto"><i class="test toto">toto</i></a>
</div>
<div class="test">
<a href="../titi">
<i class="test titi">titi</i>
</a>
</div>
<div class="test">
<a href="../tutu">
<i class="test tutu">tutu</i>
</a>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);