package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z\d@!?\-_.]{5,}$`)
var str = `test@test.com
test-test
test_test
test123
test!?
test!23
testing
testin%g
testing%
%testing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}