use strict;
my $str = 'vuser_init.c(48): Notify: Transaction "UC_13_StartPage" ended with a "Pass" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]';
my $regex = qr/(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction "(?<transaction_name>.+)" ended with a "(?<transaction_status>.+)" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}