const regex = /(?P<before>(?:(?!\[download="[^"]*" type="[^"]*"\]).)*)\[download="(?P<download>[^"]*)" type="(?P<type>[^"]*)"\](?P<after>(?:(?!\[download="[^"]*" type="[^"]*"\]).)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<before>(?:(?!\\[download="[^"]*" type="[^"]*"\\]).)*)\\[download="(?P<download>[^"]*)" type="(?P<type>[^"]*)"\\](?P<after>(?:(?!\\[download="[^"]*" type="[^"]*"\\]).)*)', 'g')
const str = `text here [download="PDC" type="A"] and the text continues [download="PDS" type="B"] and more text yet again, more shotcodes might exist ...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}