// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z0-9]+)\.([a-zA-Z0-9]{1,3})?").unwrap();
let string = "hotmail.
living.
item.
2.
4S.
hotmail.com
living.org
item.co
2.321
4S.123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}