const regex = /(name|date|location)(?:\s*([<>:]{1,2})(?:\s*))((?:(?!\b(?:and|or)\b).)+)(?:\b(and|or)\b)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(name|date|location)(?:\\s*([<>:]{1,2})(?:\\s*))((?:(?!\\b(?:and|or)\\b).)+)(?:\\b(and|or)\\b)?', 'g')
const str = `name: jill, joe, !john or date: today, yesterorday and location: location1, location2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}