$re = '/^auth\s+required\s+pam_faillock\.so\s(?|.*?(deny=(\d*))|()())?/m';
$str = 'auth required pam_faillock.so authsucc deny=4 even_deny_root unlock_time=1200
auth required pam_faillock.so authsucc even_deny_root unlock_time=1200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);