import Foundation
let pattern = ##"#([^\"|'][\S]+)|#[\"]{1}([^"]+)[\"]{1}|#[\']{1}([^']+)[\']{1}"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"Ñ‚Ð²Ð¾Ñ #погода1 ÐºÐ°ÐºÐ°Ñ Ð¿Ñ€ÐµÐºÑ€Ð°ÑÐ½Ð°Ñ #погода1 или же нет #"хорошей погоды" завтра #погода1 как вÑегда #хорошей погоды и Ñ Ð¿Ð¾Ð¼Ð¾Ñ‰ÑŒÑŽ #'золотого днÑ' ÑегоднÑ"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)